DE - ErweiterungenBBCode funktioniert nicht


12.02.2012, 01:16 - Tion1392 - webSPELL newbie - 9 Posts
Huhu,

Ich weiß, der Topic-Titel klingt nicht originell oder sonst großartig informativ. Leider ist mir nichts anderes eingefallen...
Aber kommen wir zum Kern meines Problems:
Ich schreibe derzeit ein Addon für Webspell und ich bekomm da den BBCode nicht zum laufen. Das komplette Addon zu Posten würde den Rahmen sprengen, aber ich gehe eh davon aus, dass ich irgend einen Trivialen Punkt übersehen habe.

Aber kommen wir mal zu dem, was ich habe:
In der Index ist der die bbcode.js eingebunden (ich benutzen zum entwickeln die aktuelle Version von Webspell und da auch nur die Original-Dateien. Sprich es handelt sich um eine unveränderte index.php).

In der addon.php steht auch folgende Zeile:
Code:
1.
eval ("\$addbbcode = \"".gettemplate("addbbcode")."\";");

In der entsprechende TEmplate-Datei wird der bbcode-Auswahlbereich dann ja mit
Code:
1.
$addbbcode
eingebunden.

Ich habe das ganze mal in einer kleinen test.php
Code:
1.
2.
3.
4.
5.
6.
7.
<?php
$_language->read_module('bbcode');
eval ("\$addbbcode = \"".gettemplate("addbbcode")."\";");

eval ("\$test = \"".gettemplate("test")."\";");
echo $test;
?>
auf den punkt gebracht. Dazu gibts dann folgende test.html:
Code:
1.
2.
3.
4.
5.
6.
7.
8.
<table width="100%" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td>$addbbcode</td>
  </tr>
  <tr>
    <td><textarea id="message" name="message">Heinz</textarea></td>
  </tr>
</table>


Die Buttons usw. funktionieren, die Tooltips werden angezeigt usw. aber es findet keine Portierung in die Textarea statt.
So langsam weiß ich auch net mehr weiter. Ich hab mihc schon dusselig gesucht, und meist lag es an einer bbcode.js die nicht eingebunden wurde. Aber da ich die in index.php eingebunden habe, sollte die ja auch wirken. Vor allem da tooltips angezeigt werden, funktioniert die ja an und für sich.

An anderer Stelle funktioniert der BBcode, sprich forum usw. sprich ich hab mist gebaut aber wo???

Bitte sagt mir, wo ich meinen unglaublich dämlichen und trivialen Fehler gemacht habe....
 
12.02.2012, 12:00 - Laulau - webSPELL user - 304 Posts
in deiner html muss es auch nochtmal eingefügt werden

Code:
1.
<script src="js/bbcode.js" language="jscript" type="text/javascript"></script>


EDIT: Ne mom muss es nicht wenn es nicht (ich sag es mal so) in ein extra fenster geöffnet wird (popup)

Signatur: Aka Laurenzo

 
12.02.2012, 12:55 - Tion1392 - webSPELL newbie - 9 Posts
Eben, es wird ja in der index includet. Daher reicht es (zumindest nach meinem Verständnis), wenn ich das in der index includet habe.
 
17.02.2012, 16:04 - Tion1392 - webSPELL newbie - 9 Posts
es funktioniert nach wie vor nicht unglücklich Weiss denn niemand woran das liegt?
 
17.02.2012, 17:04 - BlueaKaKev - webSPELL hero - 1762 Posts
Wenn ich mich nicht irre, muss das ganze innerhalb eines Formulars sein.

Code:
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
<form name="post" action="#">
<table width="100%" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td>$addbbcode</td>
  </tr>
  <tr>
    <td><textarea id="message" name="message">Heinz</textarea></td>
  </tr>
</table>
</form>


Das müsste funktionieren.
 
17.02.2012, 17:20 - Tion1392 - webSPELL newbie - 9 Posts
Danke, man muss die id="message" in der Textarea haben und name="post" im <form> dann klappts.
 
24.02.2012, 14:52 - XdaveX - webSPELL newbie - 19 Posts
Tion1392 wrote:

Danke, man muss die id="message" in der Textarea haben und name="post" im <form> dann klappts.



Hat mir gut geholfen, danke.